Mit DM-Remote im DMS arbeiten

Im Falle einer Terminalsitzung können mit Hilfe des DM-Remote verschiedene DMS-Funktionen auf einem lokalen Rechner (Client) ausgeführt werden. Beim lokalen Ausführen können Hard- und Software des Clients genutzt werden, z.B. Scanner oder Microsoft-Office-Anwendungen.

Hinweise zum Arbeiten mit DM-Remote

Thematik

Hinweise

Server

Der Server ist der physikalische Rechner, auf dem proALPHA läuft, z.B. ein Terminalserver. Auf dem Server werden die DMS-Funktionen aufgerufen und an den Client übertragen.

Client

Der Client ist der physikalische Rechner, von dem aus die Terminalsitzung gestartet wird und der DMS-Funktionen vom Server erhält, z.B. ein lokaler Arbeitsplatzrechner. Die lokale Ausführung erfolgt jeweils mit den in proALPHA erfassten DMS-Einstellungen.

Voraussetzung: Auf dem Client wird das Programm "remoteserver.exe" ausgeführt.

Port

Der Port dient zur Kommunikation zwischen Server und Client. Damit die Daten korrekt übertragen werden, muss auf beiden Rechnern derselbe Port erfasst werden, z.B. in den Einstellungen für die Remote-Verbindung.

Einstellungen für die Remote-Verbindung

Für das Arbeiten mit DM-Remote können Sie benutzerspezifische Einstellungen hinterlegen. So können Sie z.B. bestimmen, dass Dokumentdateien lokal an Ihrem Rechner (Client) mit den entsprechenden Programmen angezeigt werden.

Thema: Einstellungen für die Remote-Verbindung

Ablauf der Terminalsitzung

  • Der Benutzer startet auf seinem lokalen Rechner die Terminalsitzung.

  • Der Benutzer arbeitet in proALPHA.

  • Durch eine Aktion des Benutzers initiiert der Server den Aufruf einer DMS-Funktion, z.B. Scannen.

  • Mit Hilfe des DM-Remote werden alle benötigten Daten vom Server an den Client übertragen.

  • Der Client empfängt den Remote-Aufruf der DMS-Funktion und führt diese aus.

  • Der Benutzer arbeitet lokal mit der DMS-Funktion. So kann er z.B. Papierdokumente mit einem lokal verfügbaren Scanner einscannen.

  • Die Daten, z.B. eine Scanmappe, werden anschließend zurück an den Server übertragen.

  • Auf dem Server wird die Datei mit der von proALPHA übergebenen Beschlagwortung im proALPHA DMS archiviert.

  • Der Benutzer arbeitet in proALPHA weiter.

Erläuterungen zum Funktionsumfang von DM-Remote

DMS-Funktionen

Erläuterungen

Papierdokumente scannen und archivieren

Erläuterungen zur DMS-Funktion finden Sie im Thema "Papierdokumente scannen".

Besonderheiten beim Arbeiten über eine Remote-Verbindung

Sie starten in proALPHA einen Scanvorgang wie im DMS üblich und scannen das Papierdokument mit dem am Client verfügbaren Scanner ein. Die resultierende Scanmappe wird vom Client an den Server übertragen und anschließend auf dem Server im proALPHA DMS archiviert. Die Beschlagwortung wird dabei automatisch ermittelt.

DMS-Dokumente oder Dokumentdateien archivieren

Erläuterungen zur DMS-Funktion finden Sie im Thema "Dokumente archivieren".

Besonderheiten beim Arbeiten über eine Remote-Verbindung

DMS-Dokumente oder einzelne Dokumentdateien, die auf dem Client verfügbar sind, können Sie per Dateiauswahldialog oder per Drag & Drop (Outlook-E-Mails) mit der von proALPHA übergebenen Beschlagwortung im DMS archivieren.

Microsoft-Office-Dokumente erstellen und archivieren

Erläuterungen zur DMS-Funktion finden Sie im Thema "Microsoft-Office-Dokumente erstellen und archivieren".

Besonderheiten beim Arbeiten über eine Remote-Verbindung

Sie erstellen im proALPHA DMS ein neues Office-Dokument und wählen wie im DMS üblich eine DM-Office-Vorlage aus. Die dazu passende Microsoft-Anwendung wird auf dem Client automatisch gestartet und die benötigten Daten werden vom Server an den Client übertragen. Anschließend können Sie das Office-Dokument nach Ihren Anforderungen lokal bearbeiten. Nach der Bearbeitung archivieren Sie das Office-Dokument wie im DMS üblich direkt aus der jeweiligen Microsoft-Office-Anwendung. Die Daten werden vom Client an den Server übertragen. Das Office-Dokument wird im proALPHA DMS archiviert. Die Beschlagwortung wird dabei automatisch ermittelt.

Dokumentdateien anzeigen

Erläuterungen zur DMS-Funktion finden Sie im Thema "Dokumentdateien anzeigen".

Besonderheiten beim Arbeiten über eine Remote-Verbindung

Beim Anzeigen wird das Programm, das mit dem Dateityp der Datei verknüpft ist, im Client automatisch gestartet. Die Datei wird vom Server an den Client übertragen und in dem betreffenden Programm geöffnet. So wird z.B. eine DOC-Datei automatisch in Microsoft Word geöffnet.

DMS-Dokumente oder Dokumentdateien aus- und einchecken

Erläuterungen zur DMS-Funktion finden Sie im Thema "Dokumentdateien aus- und einchecken".

Besonderheiten beim Arbeiten über eine Remote-Verbindung

Beim Auschecken einer Dokumentdatei wird das Programm, das mit dem Dateityp der Datei verknüpft ist, im Client automatisch gestartet. Die ausgecheckte Datei wird vom Server an den Client übertragen und in dem betreffenden Programm geöffnet. Anschließend können Sie die Datei lokal bearbeiten. Nach der Bearbeitung checken Sie die Datei im DMS ein, d.h. die Datei wird vom Client an den Server übertragen und dort als neue Version archiviert.

DMS-Dokumente oder Dokumentdateien per E-Mail senden

Erläuterungen zur DMS-Funktion finden Sie im Thema "DMS-Dokumente und Dokumentdateien senden".

Besonderheiten beim Arbeiten über eine Remote-Verbindung

Zum Senden einer Dokumentdatei per E-Mail starten Sie im Client Microsoft Outlook und erstellen eine neue E-Mail. Im proALPHA DMS recherchieren Sie die gewünschten Dokumentdateien und senden diese wie im DMS üblich. Die Dokumentdatei wird dabei vom Server an den Client übertragen und als Dateianhang der neuen E-Mail angefügt. Anschließend versenden Sie die E-Mail mit dem Dateianhang von Ihrem lokalen Rechner aus.

Dokumente über die DM-Remote-Verbindung archivieren

Erläuterungen zur DMS-Funktion finden Sie im Thema "Dokumente archivieren".

Dokumente können Sie über die DM-Remote-Verbindung wie folgt archivieren:

Dokumente per Dateiauswahldialog archivieren

Dokumente per Dateiauswahldialog archivieren

  1. Öffnen Sie in proALPHA das Archivierungsszenario je nach Anwendungsfall.

    Anwendungsfälle:

    • Dokumente global archivieren

      1. Öffnen Sie das Archivierungsszenario in der Programmauswahl über den Menüpunkt Archivierung (DMS).

        Das Archivierungsszenario bestehend aus den Fenstern Archivierung (DMS) und Dateien hinzufügen wird geöffnet.

    • Dokumente kontextbezogen archivieren

      1. Öffnen Sie das Fenster der gewünschten Datensatzart, z.B. Kunden.

      2. Suchen Sie den Datensatz, zu dem Sie die Datei archivieren wollen.

      3. Wählen Sie den Menüpunkt Extras | Neues Dokument.

        Das Archivierungsszenario bestehend aus den Fenstern Archivierung (DMS) und Dateien hinzufügen wird geöffnet.

  2. Wählen Sie im Fenster Dateien hinzufügen den Menüpunkt Datei | Dateiauswahl.

    Alternativ: Klicken Sie auf die Schaltfläche .

    Im Client wird der Dateiauswahldialog Fenster öffnen geöffnet.

  3. Wählen Sie die gewünschten Dateien wie in Windows üblich aus.

    Die Dateien werden vom Client an den Server übertragen und in die Archivierungsdateiliste übernommen.

  4. Archivieren Sie die Dateien wie im DMS üblich.

Dokumente per Drag & Drop archivieren

Als Arbeitserleichterung können Sie beliebige Dateien, die auf dem Client verfügbar sind, per Drag & Drop archivieren, z.B. E-Mail-Dateien aus Microsoft Outlook. Diese Art der Remote-Archivierung erfolgt mit Hilfe des Fensters DMS Remote Dokumentenablage, in das Sie die zu archivierenden Dateien per Drag & Drop ziehen. Durch den Drop werden die Dateien vom Client an den Server übertragen. Ob die Übertragung erfolgreich war, können Sie je Datei anhand des Übertragungsstatus erkennen. Dateien, die an den Server übertragen wurden, können Sie dort - wie im DMS für die Archivierungart (global oder kontextbezogen) üblich - archivieren.

Aufbau und Inhalt des Fensters DMS Remote Dokumentenablage

Symbolleiste

Schaltflächen/Felder

Erläuterungen

Name der Datei

Datei löschen

Vordergrund

Mit dem aktiven Kontrollkästchen bestimmen Sie, dass das Fenster im Client im Vordergrund geöffnet bleibt.

Übersicht

Nach der Übertragung der Dateien können Sie im Fenster DMS Remote Dokumentenablage je Datei verschiedene Informationen in einer Übersicht einsehen. Je Datei werden in den Spalten folgende Daten angezeigt:

Spalten

Daten

Datei

Name der Datei

Verzeichnis

Verzeichnis der Datei

Status

Übertragungsstatus

Dateien, die an den Server übertragen wurden, werden mit folgendem Symbol gekennzeichnet:

Dateien, die nicht an den Server übertragen wurden, werden mit folgendem Symbol gekennzeichnet:

Zeit

Datum und Uhrzeit, zu dem der Übertragungsvorgang ausgelöst wurde.

Das Datum wird im Format TTMMJJJJHHMM angezeigt.

Dokumente per Drag & Drop archivieren

Hinweis: Wenn Sie auf dem Client das Programm "remoteserver.exe" ausführen, dann wird das Fenster DMS Remote Server automatisch geöffnet.

  1. Klicken Sie im Fenster DMS Remote Server in der Symbolleiste auf die Schaltfläche .

    Das Fenster DMS Remote Dokumentenablage wird geöffnet.

  2. Archivieren Sie die Dokumentdatei per Drag & Drop.

    Anwendungsfälle:

    • Dokumente global archivieren

      1. Ziehen Sie die gewünschten Dateien per Drag & Drop in das Fenster DMS Remote Dokumentenablage.

        In proALPHA wird das Archivierungsszenario bestehend aus den Fenstern Archivierung (DMS) und Dateien hinzufügen automatisch geöffnet.

        Die Dateien werden vom Client an den Server übertragen und im Fenster Dateien hinzufügen angezeigt.

      2. Archivieren Sie die Dateien wie im DMS üblich.

    • Dokumente kontextbezogen archivieren

      1. Öffnen Sie in proALPHA das Fenster der gewünschten Datensatzart, z.B. Kunden.

      2. Suchen Sie den Datensatz, zu dem Sie die Datei archivieren wollen.

      3. Wählen Sie den Menüpunkt Extras | Neues Dokument.

        In proALPHA wird das Archivierungsszenario bestehend aus den Fenstern Archivierung (DMS) und Dateien hinzufügen automatisch geöffnet.

        Der für den entsprechenden proALPHA Geschäftsvorgang zulässige Dokumenttyp wird in der Dokumenttypliste angezeigt. Zu dem Dokumenttyp werden in der Archivierungsbeschlagwortung die Schlagworte angezeigt.

      4. Ziehen Sie im Client die gewünschten Dateien per Drag & Drop in das Fenster DMS Remote Dokumentenablage.

        Die Dateien werden vom Client an den Server übertragen und im Fenster Dateien hinzufügen angezeigt.

      5. Archivieren Sie die Dateien wie im DMS üblich.

Administration

Erläuterungen zur Administration finden Sie im Thema Einstellungen für die DM-Remote-Verbindung.