Listen

Mit Hilfe von Listen können Sie in proALPHA erfasste Stammdaten und Bewegungsdaten ausgeben, u.a. zum Prüfen der Daten. Die unterschiedlichen Listen werden anhand von Listenarten unterschieden, die in einer Konfigurationstabelle hinterlegt sind. Die Listenarten entsprechen den Datensatzarten, deren Daten mit den Listen ausgegeben werden. So entspricht z.B. die Listenart "Kennzahlenstammblatt" der Datensatzart "Kennzahlen".

Das Layout von Listen bestimmen Sie mit Hilfe von Listenansichten, die Sie nach Ihren Anforderungen gestalten können. Zur Arbeitserleichterung können Sie dabei auf proALPHA Listenansichten zurückgreifen. Auch das Gestalten unternehmensspezifischer Listenansichten ist möglich.

Zur Unterstützung fremdsprachiger Mitarbeiter können Sie Listenansichten in mehreren Sprachen führen. So kann ein Mitarbeiter eine Liste auch in seiner Muttersprache ausgeben. In welchem Layout die Liste ausgegeben wird, bestimmt die Listenansicht, die im Druckvorlauf ausgewählt wird.

Das Anlegen von Listenansichten und das Ausgeben von Listen ist in allen Modulen von proALPHA standardisiert. Grundlegende Erläuterungen dazu finden Sie in diesem Thema. Spezielle Erläuterungen zu den einzelnen Listen finden Sie in den jeweiligen Detailthemen, z.B. "Listen zu Kennzahlen".

Begriffserläuterungen

Begriffe

Erläuterungen

Listenansicht

Oberbegriff für:

  • proALPHA Listenansichten

  • Unternehmensspezifische Listenansichten

Listennummer

Je Listenart eindeutiger Schlüssel, unter dem eine Listenansicht geführt wird

proALPHA Listenansicht

Listenansicht, die von proALPHA bereitgestellt wird.

Die proALPHA Listenansichten sind im Lieferumfang enthalten und können z.B. nach dem Update in Ihre proALPHA Installation importiert werden. Die Listenansichten sind mit dem internen Listeneditor gestaltet. Sie werden je Listenart und Anzahl unter den Listennummern 0 bis 9 geführt.

Unternehmensspezifische Listenansicht

Listenansicht, die von Ihnen selbst gestaltet und gepflegt wird.

Unter welchen Listennummern unternehmensspezifische Listenansichten geführt werden können, ist davon abhängig, wie proALPHA für das Arbeiten mit Listenansichten konfiguriert ist.

Listeneditoren

Oberbegriff für:

  • Grafischer Listeneditor

  • Interner Listeneditor

  • List & Label für Listen

Die Listeneditoren nutzen Sie zum Anlegen und Gestalten von Listenansichten.

Grafischer Listeneditor

Der grafische Listeneditor unterstützt Sie durch Grafikkomponenten ähnlich einem DTP-Programm und bietet zahlreiche Gestaltungsmöglichkeiten. Mit dem grafischen Listeneditor gestaltete Listen können nur über Drucker ausgegeben werden, die unter Windows installiert sind (Windows-Drucker).

Interner Listeneditor

Der interne Listeneditor eignet sich für die Gestaltung einfacher Listen mit wenigen Formatierungen. Er wird auch als Standardlisteneditor bezeichnet.

List & Label

Mit dem Berichtswerkzeug List & Label können Sie Daten für verschiedene Verwendungszwecke aufbereiten und ansprechend gestaltet ausgeben. Mit List & Label gestaltete Listen können nur über Drucker ausgegeben werden, die unter Windows installiert sind (Windows-Drucker).

Hinweise zu Zugriffsberechtigungen

Für die Gestaltung und die Verwendung von Listenansichten können Zugriffsberechtigungen konfiguriert sein. Das bedeutet, dass Sie u.a. eine Listenansicht nur dann gestalten können, wenn Sie Zugriffsrechte dafür haben. Wenn Sie irrtümlich eine Listenansicht gestalten oder verwenden wollen, für die Sie keine Zugriffsrechte haben, dann werden Sie in einer Systemmeldung informiert.

Zugriffsberechtigungen können außerdem für Felder in Datensätzen konfiguriert sein, deren Daten in Listen ausgegeben werden. Ob solche Zugriffsberechtigungen bei der Ausgabe geprüft und betroffene Daten ggf. nicht ausgegeben werden, ist anhand der Compilerkonstante pa_BL_Feldpruefung konfiguriert.

Arten von Listen

Thema: Arten von Listen

Aufbau und Inhalt von Listenansichten

Hinweis: Die folgenden Erläuterungen beziehen sich auf Listenansichten, die mit dem internen oder dem grafischen Listeneditor in proALPHA gestaltet werden. Erläuterungen zu Aufbau und Inhalt von Listenansichten in List & Label finden Sie in der Dokumentation zu List & Label.

Eine Listenansicht besteht aus vorgegebenen Listenabschnitten. Welche Listenabschnitte eine Listenansicht enthält, ist in der Konfigurationstabelle je Listenart vordefiniert. In der Regel enthält eine Listenansicht folgende Listenabschnitte:

  • Einen Kopfabschnitt für die Ausgabe von Daten zu der Liste, z.B. Listenbezeichnung und gewählte Datenselektion

  • Einen Datenabschnitt für die Ausgabe der Daten der selektierten Datensätze, z.B. Teilenummern, Mengen und Preise.

    Der Datenabschnitt wird als "primärer Datenbereich" bezeichnet.

  • Einen Fußabschnitt zur Ausgabe von Daten zur Ausgabe selbst, z.B. des Sachbearbeiters, der die Liste ausgegeben hat.

    Je nach Listenart sind in der Liste weitere Listenabschnitte enthalten. So enthalten z.B. Listen für Belege Listenabschnitte für die Ausgabe von Summen.

Welche Daten in der Liste ausgegeben werden, bestimmen Sie mit Hilfe von Listenfeldern, die Sie in die einzelnen Listenabschnitte einfügen. Dazu gibt es folgende Typen von Listenfeldern:

Mit Listenansichten arbeiten

Für das Arbeiten mit Listenansichten ist betriebsintern zu klären, ob Sie proALPHA Listenansichten unverändert verwenden und so von deren Aktualisierungen im Zuge von Updates profitieren wollen. Alternativ können Sie die proALPHA Listenansichten unter den vorgesehenen Listennummern unternehmensspezifisch anpassen oder unter diesen Listennummern neue unternehmensspezifische Listenansichten anlegen. Ob proALPHA Listenansichten unverändert verwendet werden oder unternehmensspezifisch angepasst werden können, ist anhand des Anwendungsparameters BL_BaseLayoutsUpdatable konfiguriert.

Unabhängig davon, wie Sie proALPHA Listenansichten verwenden, können Sie beliebig viele unternehmensspezifische Listenansichten anlegen.

proALPHA Listenansichten importieren

Die proALPHA Listenansichten werden bei der Installation oder beim Update bereitgestellt, können jedoch auch bei Ihrem Systemhaus angefordert werden. Der Import neuer oder geänderter proALPHA Listenansichten erfolgt in der Regel durch Ihren Systemverwalter. Bei Bedarf können Sie einzelne Listenansichten jedoch auch über den Listeneditor der entsprechenden Liste importieren. Weitere Erläuterungen zum Importieren der proALPHA Listenansichten finden Sie im Thema "Import und Übersetzung Listenansichten".

Listenansichten anlegen und gestalten

Für eine Liste können Sie eine Vielzahl unternehmensspezifischer Listenansichten anlegen. Dazu nutzen Sie einen Listeneditor, den Sie direkt aus dem Erfassungsfenster des betreffenden Datensatzes oder je Modul in der Programmauswahl aufrufen können (Menüpunkt Systemverwaltung | Konfiguration | Listeneditor).

In proALPHA werden folgende Listeneditoren unterschieden:

Beim Gestalten einer Listenansicht bestimmen Sie, welche Daten in der Liste ausgegeben werden, indem Sie die entsprechenden Listenfelder einfügen. Außerdem legen Sie das Layout der Liste fest.

Wie Sie eine Listenansicht gestalten, hängt davon ab, mit welchem Drucker eine Liste ausgegeben wird. Mit dem grafischen Listeneditor oder mit List & Label gestaltete Listen können nur über Drucker ausgegeben werden, die unter Windows installiert sind (Windows-Drucker).

Listenansichten in mehreren Sprachen führen

Neben der betriebsintern vorgegebenen Listensprache können Sie eine Listenansicht unter derselben Listennummer in weiteren Sprachen führen. Dazu müssen die sprachabhängigen Daten der Listenansicht jeweils in die gewünschten Sprachen übersetzt werden. Sprachabhängige Daten in einer Listenansicht sind:

  • Die Bezeichnung, unter der die Listenansicht geführt wird, z.B. "Kundenstammblatt". Die Bezeichnung erfassen Sie beim Anlegen der Listenansicht. Anhand der Bezeichnung wird die Listenansicht beim Ausgeben der Liste ausgewählt.

  • Feste Texte (Textkonstanten), z.B. Beschriftungen für die Datenfelder. Im grafischen und im internen Listeneditor fügen Sie Textfelder ein, zu denen Sie die Texte erfassen. In List & Label verwenden Sie Textobjekte.

  • Anzeigeformate von Datenfeldern mit logischen Werten. Solche Werte sind z.B. "Soll/Haben" oder "ja/nein".

    Hinweis: Für Listenansichten aus List & Label sind Übersetzungen von logischen Werten in der Datenbank hinterlegt, sodass Sie die Werte nicht übersetzen müssen.

Listenansichten können Sie jeweils in die Applikationssprachen übersetzen. Die Applikationssprachen sind in dem Anwendungsparameter SB_Languages... hinterlegt. Die Übersetzungen für eine Listenansicht erfassen Sie im jeweiligen Listeneditor manuell. Für Listenansichten aus List & Label steht dafür das Fenster Übersetzungen zur Verfügung.

Thema: Texte aus List & Label Druckvorlagen übersetzen

Für Oberflächensprachen kann die Übersetzung auch automatisiert erfolgen. Die automatisierte Übersetzung steht für folgende Listenansichten zur Verfügung:

  • Listenansichten des internen Listeneditors

    Für einzelne Listenansichten können Sie die automatisierte Übersetzung im Listeneditor starten. Für die Übersetzung mehrerer Listenansichten in einem Arbeitsschritt steht in der Systemverwaltung ein entsprechendes Tool zur Verfügung. Für die Übersetzung wird jeweils der Termbestand des proTERM Glossars genutzt. Weitere Erläuterungen zur automatisierten Übersetzung finden Sie im Thema "Import und Übersetzung Listenansichten".

  • Listenansichten aus List & Label

Listenansicht manuell übersetzen

  1. Öffnen Sie den Listeneditor der gewünschten Listenart.

  2. Suchen Sie die gewünschte Listenansicht.

  3. Erfassen Sie die Übersetzungen der sprachabhängigen Daten nach Ihren Anforderungen.

    • Bezeichnung der Listenansicht übersetzen

      1. Wählen Sie den Menüpunkt Funktion | Bezeichnungen.

        Das Fenster Bezeichnungen wird geöffnet.

      2. Wählen Sie im unteren Auswahlfeld die Sprache, in die Sie übersetzen wollen.

      3. Klicken Sie auf die Schaltfläche .

        Das Feld Bezeichnung wird zur Bearbeitung geöffnet.

      4. Erfassen Sie die gewünschte Übersetzung.

      5. Bestätigen Sie mit OK.

        Hinweis: Die Auswahl im Feld Listensprache hat keinen Einfluss auf die Übersetzung der Bezeichnung. Die erfasste Übersetzung wird für die Sprache gespeichert, die Sie zuvor im Listeneditor gewählt haben.

    • Texte oder Anzeigeformate übersetzen (interner oder grafischer Listeneditor)

      1. Wählen Sie den Menüpunkt Funktion | Designer.

        Die Listenansicht wird im Listeneditor geöffnet.

      2. Wählen Sie im Auswahlfeld die Sprache, in die Sie übersetzen wollen.

      3. Doppelklicken Sie auf das Textfeld, dessen Text Sie übersetzen wollen.

        Das Fenster Eigenschaften wird geöffnet (interner Listeneditor).

        Das Fenster Text wird geöffnet (grafischer Listeneditor).

      4. Erfassen Sie im Feld Text die gewünschte Übersetzung.

      5. Bestätigen Sie mit OK.

      6. Wiederholen Sie die Schritte 1 bis 3 für alle Textfelder, deren Texte Sie übersetzen wollen.

      7. Doppelklicken Sie auf das Datenfeld, dessen Anzeigeformat Sie übersetzen wollen.

        Das Fenster Eigenschaften wird geöffnet (interner Listeneditor).

        Das Fenster Datenfeld wird geöffnet (grafischer Listeneditor).

      8. Erfassen Sie im Feld Anzeigeformat die gewünschte Übersetzung.

      9. Bestätigen Sie mit OK.

      10. Wiederholen Sie die Schritte 1 bis 3 für alle Datenfelder, deren Anzeigeformate Sie übersetzen wollen.

      11. Klicken Sie auf die Schaltfläche .

        Alternativ: <Strg + S>

        Die Listenansicht wird in der gewählten Sprache gespeichert.

    • Texte übersetzen (List & Label Designer)

      1. Wählen Sie den Menüpunkt Funktion | Übersetzungen.

        Das Fenster Übersetzungen wird geöffnet.

        Die Texte werden zeilenweise angezeigt.

      2. Doppelklicken Sie in der Zeile des gewünschten Texts auf das Feld für die Sprache, in die Sie übersetzen wollen.

        Das Feld wird zur Bearbeitung geöffnet.

      3. Erfassen Sie die Übersetzung.

      4. Wiederholen Sie die Schritte 2 bis 3 für alle Texte, die Sie übersetzen wollen.

      5. Klicken Sie auf die Schaltfläche .

        Alternativ: <Strg + S>

        Die Übersetzungen werden zu der Listenansicht gespeichert.

Listenansicht automatisiert übersetzen

  1. Öffnen Sie den Listeneditor der gewünschten Listenart.

  2. Suchen Sie die gewünschte Listenansicht.

  3. Wählen Sie den Menüpunkt Funktion | Designer.

    Die Listenansicht wird im Listeneditor geöffnet.

  4. Wählen Sie den Menüpunkt Datei | Ansicht übersetzen.

    Die sprachabhängigen Daten der Listenansicht werden in die lizenzierten Oberflächensprachen übersetzt.

    Die Übersetzung erfolgt aus dem Termbestand der jeweiligen Sprache in proTERM. Wenn ein Term in einer Sprache nicht erfasst und somit keine Übersetzung möglich ist, dann wird der Term in der ursprünglichen Sprache beibehalten.

  5. Klicken Sie auf die Schaltfläche .

    Alternativ: <Strg + S>

    Die Listenansicht wird in den entsprechenden Sprachen gespeichert.

Listenansichten exportieren und importieren

Als Arbeitserleichterung beim Anlegen unternehmensspezifischer Listenansichten können Sie Listenansichten als XML-Dateien exportieren, um sie dann z.B. in andere proALPHA Installationen zu importieren. Beim Export werden alle Daten einer Listenansicht exportiert. Zum Import legen Sie zunächst eine neue Listenansicht unter der gewünschten Listennummer an. Beim Import wird die Listenansicht mit den importierten Daten gefüllt.

Listenansichten aus List & Label können Sie zudem als .lst-Dateien exportieren, z.B. zu Erleichterung der Fehleranalyse.

Tipp: Den Import können Sie auch nutzen, um eine proALPHA Listenansicht erneut zu importieren, z.B. wenn die vorhandene Listenansicht versehentlich verändert wurde. Beim Importieren wird die vorhandene Listenansicht nicht automatisch überschrieben. Sie entscheiden in einer Systemmeldung, ob die Listenansicht überschrieben wird.

Den Export einer Listenansicht starten Sie im Listeneditor der gewünschten Listenart über den Menüpunkt Extras | aktuelle Liste exportieren.

Den Import einer Listenansicht starten Sie im Listeneditor der gewünschten Listenart über den Menüpunkt Extras | Liste importieren.

Listenansichten pflegen

Listenansichten können Sie ändern. So können Sie z.B. weitere Listenfelder einfügen oder die Gestaltung ändern.

Eine Listenansicht können Sie löschen. Dabei wird die Listenansicht komplett in allen Sprachen gelöscht. Die Sprachversionen einer Listenansicht können nicht einzeln gelöscht werden.

Listen ausgeben und übermitteln

Je nach Art der Daten und der Liste öffnen Sie den Druckvorlauf für die Ausgabe der Liste an verschiedenen Stellen:

  • Für Listen zu Stammdaten können Sie den Druckvorlauf im Stammdatenfenster öffnen.

    • Um eine Liste mit den Daten mehrerer Datensätze auszugeben, öffnen Sie den Druckvorlauf der gewünschten Liste über das Menü Datei.

    • Um eine Liste mit den Daten des aktuellen Datensatzes auszugeben, z.B. das Teilestammblatt zu einem Teil, öffnen Sie den Druckvorlauf mit der Schaltfläche .

  • Für Listen zu Bewegungsdaten, z.B. Listen über Belege oder Buchungen, können Sie den Druckvorlauf in der Programmauswahl öffnen. Dort stehen die Druckvorläufe der Listen in der Regel im Ordner Ausgaben der jeweiligen Bewegungsdaten zur Verfügung. Bei Belegen können Sie den Druckvorlauf auch im Erfassungsfenster des betreffenden Belegs über das Menü Datei öffnen.

Im Druckvorlauf können Sie je nach Listenart die auszugebenden Daten eingrenzen. Ferner bestimmen Sie, in welcher Listenansicht und nach welcher Sortierung die Liste ausgegeben wird.

Für die Ausgabe und Übermittlung von Listen können Sie verschiedene Verfahrensweisen nutzen. Die Verfahrensweise wählen Sie in den Ausgabeoptionen. Sie können:

  • Listen drucken

  • Listen faxen

    Um die Daten einer Liste zu faxen, wählen Sie in den Ausgabeoptionen die in Ihrem Unternehmen genutzte Fax-Software. Anschließend bestimmen Sie in einem weiteren Vorlauf, an welche Faxnummer die Liste gefaxt wird.

  • Listen in Dateien ausgeben

    Die Daten von Listen können Sie in verschiedene Arten von Dateien ausgeben, z.B. in PDF-Dateien. Die gewünschte Dateiform wählen Sie in den Ausgabeoptionen. Die Ausgabe in eine Datei wird wie ein Datenexport behandelt. Je nach Konfiguration wird die Exportdatei automatisch in ein bestimmtes Verzeichnis gespeichert oder Sie bestimmen in einem weiteren Fenster den Speicherort der Exportdatei.

  • Listen in die Windows-Zwischenablage ausgeben

Hinweis: Mit dem grafischen Listeneditor oder mit List & Label gestaltete Listen können nur über Drucker ausgegeben werden, die unter Windows installiert sind (Windows-Drucker). Dies betrifft auch die Ausgabe in PDF-Dateien, da die entsprechenden Treiber als Windows-Drucker installiert sind. Wenn Sie keinen als Windows-Drucker geführten Drucker auswählen, dann werden Sie in einer Systemmeldung entsprechend informiert.

Liste drucken

  1. Öffnen Sie das Fenster der gewünschten Datensatzart.

  2. Wählen Sie den Menüpunkt Datei | ... drucken.

    Der Druckvorlauf wird geöffnet.

  3. Bestimmen Sie in den dafür vorgesehenen Feldern die Selektionskriterien, um die Daten in der Liste einzugrenzen.

  4. Klicken Sie auf die Schaltfläche Drucken.

    Das Fenster Ausgabeoptionen wird geöffnet.

  5. Wählen Sie im Feld Maschine die Maschine aus, über die der Druck gesteuert wird.

  6. Wählen Sie im Feld Drucker den gewünschten Drucker aus.

  7. Optional: Bestimmen Sie weitere Ausgabeoptionen, z.B. ob eine Druckvorschau gezeigt wird.

  8. Klicken Sie auf die Schaltfläche Drucken.

    Die Liste wird gedruckt.

Liste faxen

  1. Öffnen Sie das Fenster der gewünschten Datensatzart.

  2. Wählen Sie den Menüpunkt Datei | ... drucken.

    Der Druckvorlauf wird geöffnet.

  3. Bestimmen Sie in den dafür vorgesehenen Feldern die Selektionskriterien, um die Daten in der Liste einzugrenzen.

  4. Klicken Sie auf die Schaltfläche Drucken.

    Das Fenster Ausgabeoptionen wird geöffnet.

  5. Wählen Sie im Feld Maschine die Maschine aus, über die die Fax-Software gesteuert wird.

  6. Wählen Sie im Feld Schnittstelle die Fax-Software aus.

  7. Optional: Bestimmen Sie weitere Ausgabeoptionen.

  8. Klicken Sie auf die Schaltfläche Drucken.

    Das Fenster Telefaxversand wird geöffnet.

  9. Erfassen Sie die Daten in den dafür vorgesehenen Feldern nach Ihren Anforderungen, z.B. den Text für die Betreffzeile des Faxformulars.

  10. Bestätigen Sie mit OK.

    Die Liste wird gefaxt.

Liste exportieren

  1. Öffnen Sie das Fenster der gewünschten Datensatzart.

  2. Wählen Sie den Menüpunkt Datei | ... drucken.

    Der Druckvorlauf wird geöffnet.

  3. Bestimmen Sie in den dafür vorgesehenen Feldern die Selektionskriterien, um die Daten in der Liste einzugrenzen.

  4. Klicken Sie auf die Schaltfläche Drucken.

    Das Fenster Ausgabeoptionen wird geöffnet.

  5. Wählen Sie im Feld Maschine den Rechner, der für den Datenexport konfiguriert ist, z.B. den Rechner, der als Defaulteintrag konfiguriert ist.

  6. Wählen Sie im Feld Schnittstelle das gewünschte Exportformat, z.B. PDF-Mailversand.

  7. Klicken Sie auf die Schaltfläche Drucken.

    Abhängig vom gewählten Exportformat wird der Datenexport sofort ausgeführt, oder Sie geben zunächst Name und Verzeichnis für die Exportdatei an.

Liste in die Windows-Zwischenablage ausgeben

  1. Öffnen Sie das Fenster der gewünschten Datensatzart.

  2. Wählen Sie den Menüpunkt Datei | ... drucken.

    Der Druckvorlauf wird geöffnet.

  3. Bestimmen Sie in den dafür vorgesehenen Feldern die Selektionskriterien, um die Daten in der Liste einzugrenzen.

  4. Klicken Sie auf die Schaltfläche Drucken.

    Das Fenster Ausgabeoptionen wird geöffnet.

  5. Wählen Sie im Feld Maschine die Maschine aus, über die die Ausgabe in die Zwischenablage gesteuert wird.

  6. Wählen Sie im Feld Schnittstelle den Eintrag für die Zwischenablage.

  7. Klicken Sie auf die Schaltfläche Drucken.

    Die Liste wird in die Windows-Zwischenablage ausgegeben.

Administration

Objekte

Bedeutung

Konfigurationstabelle Listenarten

Vordefinierte Listenarten

BJ_GeneratorTypes...

Generatortypen für die Gestaltung von Formularvorlagen und Listenansichten

BL_BaseLayoutsUpdatable

Festlegung, ob die Listennummern 0 bis 9 für unternehmensspezifische Listenansichten verfügbar sind oder den proALPHA Listenansichten vorbehalten sind

BU_ConventionalPrintPreviewMax...

Fenstergröße der Druckvorschau bei Formularen des Standardformulargenerators und Listen des Standardlisteneditors

pa_BJ_ReportCopies

Festlegung, ob für das Ausgeben Ausfertigungen hinterlegt werden können

Listen

Unternehmensspezifische Konfiguration für den Import und die Übersetzung von Listenansichten

Zugriffsberechtigungen

Thema: Zugriffsberechtigungen für Listen einrichten

Zugriffsberechtigungen für Listen einrichten

Für Listen können Sie folgende Zugriffsberechtigungen einrichten:

  • Zugriffsberechtigungen für die Listeneditoren.

    Der Zugriff auf einen Listeneditor kann mit der Programmverriegelung komplett, d.h. für das Programm, oder für einzelne Listenarten, d.h. Instanzen des Programms, gesperrt werden.

  • Zugriffsberechtigungen für Listenansichten.

    Einzelne Listenansichten können mit der Satzverriegelung für die Bearbeitung sowie mit der Benutzungsverriegelung für die Verwendung gesperrt werden.

Zusätzlich können Sie anhand der Compilerkonstante pa_BL_FeldPruefung konfigurieren, ob bei der Ausgabe von Listen die Felder der Daten auf Zugriffsberechtigungen geprüft werden.