Automatisierte Belegausgabe steuern und überwachen

Die automatisierte Belegausgabe erfolgt in der Regel automatisiert in der WorkflowAutomation. Bei Bedarf können die verschiedenen Schritte der Belegausgabe in der Systemverwaltung auch manuell gestartet werden, z.B. wenn bei der Belegausgabe Fehler aufgetreten sind.

Zu Überwachung und Steuerung der Belegausgabe stehen folgende Hilfsmittel zur Verfügung:

  • Übersicht aktive Belegausgaben

  • Verarbeitungsprogramm Verarbeitung Belegausgabe

Belegausgaben einsehen und bearbeiten

Sobald für einen Beleg die automatisierte Belegausgabe angefordert wird, werden die Belegdaten entsprechend dem Ausgabeprozess für die Ausgabe aufbereitet und bereitgestellt. Dabei entsteht je Beleg ein Ausgabevorgang. Der Ausgabevorgang bündelt alle Daten, die laut Ausgabeprozess für die Ausgabe vorgesehen sind. So wird z.B. für den E-Mail-Versand ein Formular mit den Belegdaten nach der zum Beleg hinterlegten Formularvorlage angelegt und in eine PDF-Datei gespeichert.

Die Ausgabevorgänge werden in der Übersicht aktive Belegausgaben aufgelistet. In der Übersicht können Sie die Ausgabevorgänge mit Hilfe eines Filters eingrenzen, z.B. nach der Belegart. Je Ausgabevorgang können Sie verschiedene Daten einsehen, u.a. den aktuellen Trackingstatus des Belegs. Abhängig davon, wie die Belegausgabe konfiguriert ist, kann dies z.B. der Initialstatus für den Ausgabeprozess sein. Der Trackingstatus informiert darüber, wie die Belegausgabe bisher verlaufen ist. So erhalten Belege, die auf Grund eines Fehlers überhaupt nicht oder nicht auf allen vorgesehenen Ausgabewegen ausgegeben wurden, den Trackingstatus "Fehler bei Belegausgabe aufgetreten". Detailinformationen zum Ausgabeverlauf sowie eine Beschreibung des Fehlers sehen Sie im Infofenster Belegausgabe (Menüpunkt Funktion | Detail zu dem Ausgabevorgang). Hier können Sie u.a. den Verlauf der Ausgabe anhand der einzelnen Ausgabeschritte nachvollziehen (Tracking). Zusätzlich können Sie den Beleg selbst einsehen (Menüpunkt Funktion | Beleg). Im Beleg erkennen Sie den aktuellen Trackingstatus anhand eines farbigen Schaltflächensymbols.

Zur Beseitigung der Fehlerursache sind je nach Art des Fehlers unterschiedliche Maßnahmen erforderlich. Wenn z.B. beim E-Mail-Versand für den vorgesehenen Empfänger keine E-Mail-Adresse ermittelt werden konnte, dann muss die Adresse in den Stammdaten des Empfängers erfasst werden. Nach der Beseitigung der Fehlerursache können Sie den Ausgabevorgang freigeben (Menüpunkt Bearbeiten | Ausgabe freigeben) und anschließend die Ausgabe manuell starten. Die Freigabe können Sie auch wieder zurücknehmen, indem Sie die Ausgabe unterdrücken (Menüpunkt Bearbeiten | Ausgabe unterdrücken).

Wenn ein Beleg nicht ausgegeben werden soll, dann archivieren Sie den Ausgabevorgang des Belegs.

Hinweis: Bei der erneuten Ausgabe nach Beseitigung der Fehlerursache werden nur noch die Ausgabewege berücksichtigt, bei denen zuvor ein Fehler aufgetreten ist. Auch bleiben die Einstellungen sowie die auszugebenden Belegdaten unverändert, es wird z.B. keine neue PDF-Datei erzeugt. Wenn Sie die komplette Belegausgabe wiederholen wollen, dann müssen Sie den aktuellen Ausgabevorgang archivieren und die Belegausgabe für den Beleg erneut anfordern.

Tipp: Sie können auch mehrere Ausgabevorgänge in einem Arbeitsschritt freigeben, unterdrücken oder archivieren. Markieren Sie dazu in der Übersicht die Zeilen der gewünschten Ausgabevorgänge wie in Windows üblich und wählen Sie den gewünschten Menüpunkt, z.B. Bearbeiten | Ausgabe freigeben.

Besonderheiten bei der DMS-Archivierung von Belegen

Bei entsprechender Konfiguration des Ausgabeprozesses wird automatisch eine PDF-Datei mit den Belegdaten im DMS archiviert. Die Archivierung erfolgt im Anschluss an die Belegausgabe und ist Teil des Ausgabevorgangs.

Hinweis: Die Archivierung bei der Belegausgabe ist keine COLD-Archivierung.

Wenn bei der Archivierung ein Fehler auftritt, z.B. weil der DMS-AppServer nicht verfügbar ist, dann erhält der Ausgabevorgang den Trackingstatus "Fehler bei Belegausgabe aufgetreten". Gleiches gilt für den Beleg. In der Detailinformation zum Trackingstatus des Belegs sehen Sie zudem die Fehlerursache. Nach Beseitigung der Fehlerursache können Sie die Archivierung erneut starten, indem Sie den Ausgabevorgang in der Übersicht aktive Belegausgaben manuell archivieren (Fenster Menüpunkt Bearbeiten | Ausgabe archivieren). Wenn die Archivierung erneut scheitert, dann wird für den Beleg ein weiterer Eintrag mit dem Trackingstatus "Fehler bei Belegausgabe aufgetreten" protokolliert. Der Ausgabevorgang als Ganzes behält den Trackingstatus.

Besonderheiten bei Anfragen

Anfragen werden immer einzeln ausgegeben. Eine Anfrage wird in der Regel für mehrere Lieferanten ausgegeben, hat also mehrere Empfänger. Daher entsteht beim Anfordern der Belegausgabe nicht je Anfrage, sondern je Empfänger der Anfrage ein Ausgabevorgang. Zur Unterscheidung der Ausgabevorgänge wird in der Spalte Ausgabebezug jeweils die Lieferantennummer angezeigt.

Da die einzelnen Ausgabevorgänge unterschiedliche Trackingstatus haben können, wird im Beleg selbst kein Trackingstatus angezeigt.

Ausgabevorgänge archivieren

Wenn die Belegausgabe abgeschlossen ist, dann wird der zugehörige Ausgabevorgang automatisch zu dem Beleg archiviert. Sie können einen Ausgabevorgang jedoch auch manuell archivieren. Einen Ausgabevorgang können Sie archivieren, wenn er den Trackingstatus "Belegausgabe unterdrückt" hat. Ausgabevorgänge mit den Trackingstatus "Freigabe Belegausgabe angefordert" und "Freigabe Belegausgabe erfolgt" können Sie also nicht direkt archivieren. Um einen solchen Ausgabevorgang zu archivieren, müssen Sie die Ausgabe zunächst unterdrücken (Menüpunkt Bearbeiten | Ausgabe unterdrücken), sodass der Ausgabevorgang den Status "Belegausgabe unterdrückt" erhält.

Einen Ausgabevorgang müssen Sie z.B. manuell archivieren, wenn der zugehörige Druckauftrag nach dem Auftreten eines Fehlers manuell aus der Job-Konsole gelöscht wurde. In diesem Fall wird der Trackingstatus "Belegausgabe unterdrückt" gesetzt.

Beim Archivieren können Sie unterschiedlich vorgehen:

  • Sie können den Ausgabevorgang archivieren, ohne die Ausgabe zu beenden.

    Dazu nutzen Sie den Menüpunkt Bearbeiten | Ausgabe archivieren. Bei dieser Vorgehensweise wird der Ausgabevorgang archiviert. Wenn im Ausgabeprozess neben dem Druck auch die DMS-Archivierung des Belegs vorgesehen ist, dann versucht das System, die DMS-Archivierung durchzuführen.

    Der Trackingstatus im Beleg bleibt bei "Belegausgabe unterdrückt" (), so dass Sie die Ausgabe erneut anfordern können.

  • Sie können den Ausgabevorgang archivieren und zugleich die Ausgabe beenden.

    Dazu nutzen Sie den Menüpunkt Bearbeiten | Ausgabe beenden und archivieren. Bei dieser Vorgehensweise wird der Ausgabevorgang ohne weitere Verarbeitung archiviert. Eine ggf. vorgesehene DMS-Archivierung wird nicht versucht. In diesem Fall müssen Sie dafür sorgen, dass die Ausgabe auf anderem Wege erfolgt, z.B. indem Sie die Ausgabe manuell starten.

    Der Trackingstatus im Beleg wechselt zu "Belegausgabe erfolgreich beendet" ().

Hinweis: Die Dateien mit den ausgegebenen Dokumenten werden entsprechend der für Belegausgaben hinterlegten Speicherdauer zu dem Ausgabevorgang gespeichert. Nach Ablauf der Speicherdauer werden die Dateien im Tagesabschluss automatisch gelöscht.

Ausgabe manuell starten

Die Ausgabe erfolgt in der Regel automatisiert über einen permanenten Job. Der Job wird beim Konfigurieren der automatisierten Belegausgabe eingerichtet. Bei Bedarf können Sie die Verarbeitung der Ausgabevorgänge anhand des Verarbeitungsprogramms Verarbeitung Belegausgabe auch manuell starten. Dabei bestimmen Sie jeweils, welche Belege berücksichtigt werden. Beim Ausführen des Verarbeitungsprogramms werden die aktuell zur Ausgabe bereitstehenden Belege sofort ausgegeben.

Hinweis: Beim manuellen Starten wird der entsprechende Job im Vordergrund ausgeführt, sodass während der Ausführung nicht in proALPHA gearbeitet werden kann. Daher wird der Job nach der Belegausgabe grundsätzlich wieder beendet. Dies ist unabhängig von der Einstellung des Kontrollkästchens Endlosverarbeitung im Vorlauf der Belegausgabe.

Belegausgaben überwachen

Die Belegausgabe kann mit der WorkflowAutomation überwacht werden. Anhand der WorkflowAutomation können Sachbearbeiter über anfallende Arbeitsschritte informiert werden. Dazu sind für die WorkflowAutomation für die automatisierte Belegausgabe verschiedene Ereignisse und Vorgänge vordefiniert.

Vorgänge, die auf Grund von Ereignissen anfallen, werden in der WorkflowAutomation automatisch in die Aufgabenmonitore der zuständigen Sachbearbeiter gestellt. Dort können die Sachbearbeiter die angefallenen Vorgänge abarbeiten.